"Failed to import Solarwinds SDK" Error Message Resolution

    Problem Description

    While testing the API server for SolarWinds API adapter, we see the following error message - Failed to import Solarwinds SDK

     

    Root Cause

    This issue occurs when Orion SDK Python library is missing from the NetBrain Front Server.

    To support SolarWinds data retrieval, the Orion SDK must be deployed on each Windows based machine where the NetBrain Front Server service is running in the customer environment.

     

    Resolution

    1. Download the SolarWinds Orion SDK, orion.zip, from the attachments and stage locally in the C:\Temp directory on each NetBrain Windows server where the Front Server service is currently running.
    2. Log into the first NetBrain Front Server machine with the administrator user.
    3. Using Windows Explorer, navigate to the C:\Temp directory
    4. Unzip the orion.zip file locally in the C:\Temp directory
    5. Copy the resulting directories, orionsdk and orionsdk-0.0.6.dist-info, to the NetBrain Front Server service python library

    C:\Program Files\NetBrain\Front Server\python\Lib\site-packages

    1. We have finished deploying the libraries in the server.  Test the API server again.
    2. If this does not resolve the issue, contact NetBrain Technical Support at support@netbraintech.com and reference this Knowledge Base article.

     

     

    Integrated Edition 8.0Integrated Edition 8.01Integrated Edition 8.02Integrated Edition 8.03

    Attachments


    Tags

    IntegrationSolarWindsSingle Pane of Glass

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